Jumperserver 升级到 1.5.0-2

  |   0 评论   |   0 浏览

  原有的 jumperserver1.4.5 因为被我加了个菜单,不能直接升级

备份更新

备份原有的 jumpserver

  mv jumperserver jumperserver.bak

回滚 jumperserver

1git clean -df  # 清除未跟踪文件, 请一定要做好备份后再操作此步骤
2git reset --hard  # 还原所有修改, 请一定要做好备份后再操作此步骤

更新代码

1# 更新 config.yml, 请根据你原来的 config.bak 内容进行修改
2 mv config.py config_1.4.5.bak
3 cp config_example.yml config.yml
4 vi config.yml

  因为 1.5.0 的配置文件改动比较大,对比原先的配置文件进行修改

 1# SECURITY WARNING: keep the secret key used in production secret!
 2# 加密秘钥 升级请保证与你原来的 SECRET_KEY 一致, 可以从旧版本的config_1.4.5.bak配置文件里面获取
 3SECRET_KEY: *****
 4
 5# SECURITY WARNING: keep the bootstrap token used in production secret!
 6# 预共享Token koko和guacamole用来注册服务账号, 不在使用原来的注册接受机制, 可随机生成
 7BOOTSTRAP_TOKEN: *****
 8
 9# Development env open this, when error occur display the full process track, Production disable it
10# DEBUG 模式 开启DEBUG后遇到错误时可以看到更多日志
11DEBUG: false
12
13# DEBUG, INFO, WARNING, ERROR, CRITICAL can set. See https://docs.djangoproject.com/en/1.10/topics/logging/
14# 日志级别
15LOG_LEVEL: ERROR
16# LOG_DIR:
17
18# Session expiration setting, Default 24 hour, Also set expired on on browser close
19# 浏览器Session过期时间, 默认24小时, 也可以设置浏览器关闭则过期
20# SESSION_COOKIE_AGE: 86400
21SESSION_EXPIRE_AT_BROWSER_CLOSE: true
22
23# Database setting, Support sqlite3, mysql, postgres ....
24# 数据库设置
25# See https://docs.djangoproject.com/en/1.10/ref/settings/#databases
26
27# SQLite setting:
28# 使用单文件sqlite数据库
29# DB_ENGINE: sqlite3
30# DB_NAME:
31
32# MySQL or postgres setting like:
33# 使用Mysql作为数据库
34DB_ENGINE: mysql
35DB_HOST: 127.0.0.1
36DB_PORT: 3306
37DB_USER: jumpserver
38DB_PASSWORD: *****
39DB_NAME: jumpserver
40
41# When Django start it will bind this host and port
42# ./manage.py runserver 127.0.0.1:8080
43# 运行时绑定端口
44HTTP_BIND_HOST: 0.0.0.0
45HTTP_LISTEN_PORT: 8080
46
47# Use Redis as broker for celery and web socket
48# Redis配置
49REDIS_HOST: 127.0.0.1
50REDIS_PORT: 6379
51# REDIS_PASSWORD:
52# REDIS_DB_CELERY: 3
53# REDIS_DB_CACHE: 4
54
55# Use OpenID authorization
56# 使用OpenID 来进行认证设置
57# BASE_SITE_URL: http://localhost:8080
58# AUTH_OPENID: false  # True or False
59# AUTH_OPENID_SERVER_URL: https://openid-auth-server.com/
60# AUTH_OPENID_REALM_NAME: realm-name
61# AUTH_OPENID_CLIENT_ID: client-id
62# AUTH_OPENID_CLIENT_SECRET: client-secret
63
64# OTP settings
65# OTP/MFA 配置
66# OTP_VALID_WINDOW: 0
67# OTP_ISSUER_NAME: Jumpserver

安装启动

1pip install -r requirements/requirements.txt
2./jms start all -d

更新 luna

1$ cd /opt
2$ rm -rf luna luna.tar.gz
3$ wget https://github.com/jumpserver/luna/releases/download/1.5.0/luna.tar.gz
4
5# 如果网络有问题导致下载无法完成可以使用下面地址
6$ wget https://demo.jumpserver.org/download/luna/1.5.0/luna.tar.gz
7
8$ tar xf luna.tar.gz
9$ chown -R root:root luna

注意把浏览器缓存清理下

Docker koko Guacamole

  说明: Docker 部署的 koko 与 guacamole 升级说明

 1# 先到 Web 会话管理 - 终端管理 删掉所有组件
 2$ docker stop jms_koko
 3$ docker stop jms_guacamole
 4
 5$ docker rm jms_koko
 6$ docker rm jms_guacamole
 7$ docker pull jumpserver/jms_koko:1.5.0
 8$ docker pull jumpserver/jms_guacamole:1.5.0
 9
10# BOOTSTRAP_TOKEN 请和 jumpserver 配置文件中保持一致
11$ docker run --name jms_koko -d -p 2222:2222 -p 5000:5000 -e CORE_HOST=http://<Jumpserver_url> -e BOOTSTRAP_TOKEN=***** -e LOG_LEVEL=ERROR jumpserver/jms_koko:1.5.0
12$ docker run --name jms_guacamole -d -p 8081:8081 -e JUMPSERVER_SERVER=http://<Jumpserver_url> -e BOOTSTRAP_TOKEN=***** jumpserver/jms_guacamole:1.5.0
13
14# 到 Web 会话管理 - 终端管理 查看组件是否已经在线

  最后修改 jumperserver 模版中的_nav.html,把原来修改的加上

  截图如下

  image.png

---------------------------------------------------------------
>> 博客地址:https://blog.mufengs.com
>> 邮箱地址:[email protected]
>> 微信帐号:Do8080
>> Github : https://github.com/mufengcoding
---------------------------------------------------------------